This project is read-only.

Issues installing on Samsung Omnia 2

Jan 11, 2010 at 2:28 PM

Using a Samsung Omnia 2 with WinMo 6.5

I installed using the TouchRC.CAB

Upgraded to .net 3.5

vmccontroller already setup on MediaPC

Installs fine, I get the start-up screen Choose Computer, I Add Computer by filling in the IP (and/or PC name) , then hit check and this is what I get:

 

Error

An unexpected error has occured in TouchRC.exe

Select Quit and then restart this program, or select Details for more information.

 

clicking Details gets this:

 

Error

TouchRC.exe

UnauthorizedAccessException

   at

System.IO._Error.WinIOError(Int32errorCode, String str)

   at System.IO.FileStream..ctor(Stringpath, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean useAsync, String msgPath)

   at System.IO.FileStream..ctor(Stringpath, FileMode mode, FileAccess access, FileShare share)

   at

System.Xml.XmlTextWriter..ctor(String filename, Encoding encoding)

   at

TouchRC.Logic.ConfigSettings.SaveConfigs(List``1 computers)

   at

TouchRC.Logic.ConfigSettings.AddComputerConfigs(ComputerListBoxItemcomputer)

   at

TouchRC.ComputerConfigPanel.m_SaveButton_Click(Object sender, EventArgs e)

   at

Fluid.Controls.FluidControl.PerformClick()

   at

Fluid.Controls.FluidButton.PerformClick()

   at

Fluid.Controls.FluidControl.OnClick(PointEventArgs e)

   at

Fluid.Controls.FluidButton.OnClick(PointEventArgsp)

   at

Fluid.Controls.ControlContainer.OnClick(PointEventsArgs p)

   at

Fluid.Controls.ControlContainer.OnClick(PointEventsArgs p)

   at

Fluid.Controls.FluidHost.OnMouseUp(MouseEventArgs e)

   at

System.Windows.Forms.Control.WnProc(WM wm,Int32 wParam, Int32 IParam)

   at

System.Windows.Forms.Control._InternalWnProc(WMwm,Int32 wParam, Int32 IParam)

   at

Microsoft.AGL.Forms.EVL.EnterMainLoop(IntPtr hwnMain)

   at

System.Windows.Forms.Application.Run(Form fm)

   at TouchRC.Program.Main()

 

Let me know if you have any ideas, this would be great app to get working on my Mobile!

Jan 11, 2010 at 8:05 PM

Apparently it's because the settings.xml file is 'read-only'. Not sure why it's only in this release it's become read only! A work around is to make it not read only either via active sync or using something like RescoExplorer.

 

Hope this helps,

 

Evorgevol

Jan 11, 2010 at 8:27 PM

OK.

now I've got the o.3 working, but play buttons aren't working (win 7 thing I guess).

It would be nice to get the 0.4 working though.

 

Also I'm wondering if there's a way to change the background colour of the remote and now playing screen from blue to black. possibly changing the button arrangement as well. (I don't code, but could "photoshop" an idea together :) )

Jan 11, 2010 at 10:52 PM

I'll have another look at the code at some point, not really sure why it worked in 0.3 but not 0.4, I didn't change anything in that area!! (i dont think..)

 

If you change the images in the 'gfx' directory in wherever you installed the app to, then you can change the background image and any other images you like! :)

Jan 12, 2010 at 4:49 PM

Thanks for replying!

I'm really impressed by your program, it's a great solution for a Home Media Center. I appreciate that it's fairly lightweight, something other apps aren't!

If there's any specific info you need from me regarding my install of 0.4, let me know.

 

thanks Will.

Jan 26, 2010 at 5:31 PM

So I'm still not getting the Player buttons to work (no play pause track stop etc.) everything else seems ok.

how do I go abouts checking if the problems the pocket pc (touch rc) or if its coming from VistaMediaCenterTCP/IP?

I'm running Windows 7 MC with the vmccontroller win7 alpha release (which says player Button-* are working?)

thanks .

Feb 10, 2010 at 8:52 AM

Hi Evorgevol,

I'm experiencing the same issues that WillFi is reporting.  I haven't tried 0.4 yet (didn't read the readonly file work around until too late).  0.3 is working for me, but not the start / stop /  rewind buttons etc.  I'll have a look into this tomorrow to see if I can figure out whats going wrong.

FYI, my setup is a Palm Treo Pro (WM 6.1) connecting to a Win 7 media center.

Cheers,

Nick

Feb 19, 2010 at 8:34 AM

Hi @ all.

 

I have the same Problem, that the Play, Stop, etc. Buttons don't work.

I have tested the VMCController without the fantastic TouchRC, and...
...the Buttons aren't functional either!

So it is a Problem in VMCController.

I'm using VMCController Win7 Alpha (x86), so i can't say if the bug exist also in the VMCController for Vista and below.
Perhaps the Buttons are only fixed in the Vista Controler version, not in the Win 7 Version...

 

Regards,

Jan