This project is read-only.

Local PC's only?

Jun 2, 2009 at 4:40 PM

Just want to say, great application.  I look forward to seeing/using the progress.  A few questions:

1) I'm not home so I can't test this locally, but I am trying to test it remotely with no luck.

-Ive had VMC controller installed for a while and it can use it remotely just fine, so I'm pretty sure thats not the problem.

- I have a static domain mapped to my dynamic ip address through dyns  in the following format;    Name.homeip.net   

note: I have all the port forwarding setup on my router properly.

So, for VMC Controller I can access my machine remotely using http://Name.homeip.net:40500

I used my domain in the address of the setup but when I try to send a command I get an "Invalid IP address" msg and the app shuts down.  So, I guess the short version of my question is this local IPs only or does it support domains?

 

Also, how can you remove a computer from the list?

Jun 3, 2009 at 11:11 AM

Last night I implemented it to use Dns.Resolve, so hopefully that will solve the issue of it working only on local computers. (Please let me know if it doesn't and I'll have a look into it).


To remove/edit an existing computer, press and hold on the computer (for longer than one second) to give u edit/remove options. Press and hold again to remove the options. (Sorry, forgot to write that one down anywhere!)

 

Thanks,

 

evorgevol

Jun 3, 2009 at 1:40 PM

Thanks for the timely response.  I tried it this morning and still no luck.  Just to verify I was able to control via a http request

http://name.homeip.net:40510/button-up

Now, I noticed that your program defaults to 40500.  I changed the port number to 40510, the default for http request.  Could that be an issue.

The addresses I tried were

http://name.homeip.net

And

name.homeip.net

 

Both gave the invalid address error.

 

Let me know if there is anything else you want me to try.  Looking forward to getting this squared away.

 

Thanks.

Jun 3, 2009 at 1:48 PM

I will set up port forwarding on my router and have a play around with it tonight.

The port you should be using (assuming you've kept the defaults) is 40500. 40510 is purely for the http server. Just to check that you have ports 40400, 40500 and 40510 set up for port forwarding? (Though that doesnt explain why it's giving an invalid address error). I'll have a play around with mine later and let you know how I get on.

evorgevol

Jun 3, 2009 at 2:17 PM

I honestly cant remember if I set up 40400 and 40500 for port forwarding so that could very well be the problem.

Just another question, will this work with extenders as well. Assuming the ports are configured properly?

Jun 3, 2009 at 2:53 PM

It should do. That is more of a feature of VmcController than my app, you just need to increment the port number by one per extender.

I've just had a play around with it at work (so not actually using my app), and just trying to connect to my home pc via telnet but to no avail. The http server works fine, but not the other ports. So this maybe an issue with VmcController, and not my application. I will have another play around tonight with the app, just to double check this.

 

evorgevol

Jun 10, 2009 at 5:51 PM

So last week my computer died so I was unable to verify anything furter, but my new rig is built and I just wanted to let you know your app works perfectly.  Im looking forward to more features.  Any ideas as to what you are tackling next?

Jun 11, 2009 at 9:25 AM

Excellent, glad to hear it!!! :)

I'm currently working on a 'Media Browser', a way of navigating through all the cached metadata to select films/tv shows to watch. Though, for some unknown reason, I seem to have a social life, so progress is slow on this update..! :)

 

Thanks,

 

evorgevol